Welcome Guest Search | Active Topics | Log In | Register

Unable to receive inbound calls Options
RobertT2
#1 Posted : Wednesday, August 19, 2009 10:59:09 PM

Rank: Soho66 Staff Member

Groups:

Joined: 8/17/2009
Posts: 94
Unable to receive inbound calls

It is quite common, when setting the service up to find that you can make calls, but that when trying to receive calls, your number just goes voicemail and your IP phone never rings.

It is most likely that this will happen intermittently. On rare occasions (with some routers) it may even start happening after some time using the service trouble free.

Background on why this happens

When an incoming call comes to our system and we want to route the call to your IP phone, we first look up the location of your phone on the Internet. The location of your phone is comprised of two separate components: The public IP address of your phone and the port number of your phone.

The public IP address is actually the address, on the Internet, of your Internet router. As public IP addresses are limited, you will typically only have one such address allocated to you.

As you can have many devices connected to your router, in order for your router to know which device to send the call to, we also specify a port number. This port number is known to us, as we recorded which port number the traffic came from when your phone registered with our server.

Now, your router can close this port off after registration or fail to route traffic to your phone when it arrives on this port. As we cannot contact your phone, we move on to the next step in your routing, which is usually to go to voicemail.

Causes and resolutions

Your router can fail to route our call to your phone for a number of reasons:

1. Some phones provide the option to 'register with domain and receive incoming calls', this option is called different things on different phones and is the simplest reason at all that your phone will be unable to receive incoming calls. Check for the presence of any such option and make sure that it is enabled. All know hardware and software phones either do not provide such an option or have it enabled by default. In other words, if you don't remember changing that option, then that's not the cause of your issue.

2. The port on your router has become closed due to a lack of activity. This is the most common fault and is easy to fix. You should configure your phone to send a 'keep alive' packet to us. Look in your phones settings for an option such as 'NAT reresh', 'NAT keepalive', 'Keepalive', or even in STUN settings it may have an option such as 'No, but send keep alive'. Keep alive should be switched on, with a refresh time of around 20 seconds. Note that the X Lite soft phone does this automatically

3. If you have multiple phones on your local network and only one of them can ever receive incoming calls at any given time then the likely problem is that your router is only able to handle a single connection from any given port at a time. Have a look for the setting for 'Local SIP port' for your phones and alter each phone so it uses a different local SIP port. Choose any port numbers around 5060, just make sure that they are all different.

4. If you've tried or ruled out all the above then your router may be intercepting the VoIP traffic and is either altering it (ALG) or failing to route it on to your phone. This is the most difficult scenario to tackle. Check our section on routers and troubleshooting in the forum for advice on what routers are known to be problematic and suggestions on resolving the issue.

DarylB
#2 Posted : Tuesday, December 08, 2009 2:25:47 PM

Rank: Soho66 Staff Member

Groups:

Joined: 7/9/2009
Posts: 60
One thing to try when your phone is not receiving calls, and ALG is suspected as the cause of the problem, is to try changing the port number on our server that your phone registers with. We offer SIP registrations on two different port numbers. Simply changing your phone settings to register with our alternate port may well cure your issue.

Please see our guide to changing the port number at http://soho66.co.uk/forum/default.aspx?g=posts&m=87
MartinM2
#3 Posted : Monday, September 19, 2011 11:11:00 AM
Rank: Newbie

Groups:

Joined: 9/19/2011
Posts: 1
Just started using this service with the 3CX phone today and couldn't receive calls.

I had a bit of a head scratch, realised I was using Win 7 so I opened the 3CX phone as administrator and presto! it works.

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Soho66 Theme by Daryl Burns (Soho66) (Soho66)
Powered by YAF 1.9.3 | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 5.005 seconds.