Welcome Guest Search | Active Topics | Log In | Register

Thomson / BT Home Hub routers Options
RobertT2
#1 Posted : Friday, August 21, 2009 10:55:30 AM

Rank: Soho66 Staff Member

Groups:

Joined: 8/17/2009
Posts: 94
Thomson / BT Home Hub routers

Thomson routers, which form the basis of the BT HomeHub, are the most problematic routers we deal with on a daily basis.

The router itself routinely fails to fail to forward SIP responses back from our servers to customer phones.

It also sends keep alives on a different port number to the original registrations, causing the registered port to close after a short time.

The sort of symptoms you will see are:

1. Your SIP phone fails to register (this may even start happening after a long period of operating just fine)
2. Inbound calls are not received or are received intermittently
3. Outbound calls are cut off after a short period (around 30 seconds). This behaviour is usually consistent

Steps to resolve

There are a number of solutions that have worked for us in the past. Not all of these work on all routers, but generally speaking, a combination of one or all of these steps will yield success.

1. Fool the router into thinking that the traffic is not VoIP traffic.

The router is intercepting VoIP traffic on a selective basis. By fooling the router into thining that the traffic isn't VoIP, we can circumvent this process.

There are two ways to do this. Try the first and then if that doesn't work, try both

(a) Change the local port that your phone uses for sending traffic. This setting is called different things on different devices, but essentially, you're looking for a setting such as 'SIP local port' or 'Local port' or in some instances 'Listen port'. Change this to something that isn't 5060 (the default SIP port). Reboot and try again
(b) We offer our service on an alternate port number to 5060. Change the registrar domain (and any other references to our VoIP domain) by adding a :8060 to the end. So for example, if your phone is registered to sip.soho66.co.uk then change this to read sip.soho66.co.uk:8060. Reboot and try again

Disable UPnP.

UPnP is enabled by default on the BT Homehub and Thomson routers. UPnP is supposed to make life easier for SIP devices, but the poor implementation on these devices wreaks havoc with SIP.

To disable UPnP:

i. Log on to your routers web interface (for BT Home Hub this is on 192.168.1.254 default username = admin, password = admin).
ii. You may need to switch to admin user to access the config menus (click on [admin] then Switch to Another User)
iii. Click on Toolbox >> Game and Application Sharing then click on configure
iv. Untick the box that says 'Use UPnP'
v. Save your settings and then reboot the phone and then router

Note that UPnP is a major security risk on the HomeHub and should always be disabled in any instance.

If you still continue to experience issues you should

i. Do a factory reset on the router (consult the user guide for details on how to do this)
ii. When the device reboots, make sure that no VoIP devices are connected.
iii. After reset, disable UPnP as above
iv. Re plug your VoIP devices and try again

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Soho66 Theme by Daryl Burns (Soho66) (Soho66)
Powered by YAF 1.9.3 | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 2.201 seconds.