Welcome Guest Search | Active Topics | Log In | Register

Asterisk + FreePBX (Trixbox, Elastix, etc) Options
DarylB
#1 Posted : Monday, November 23, 2009 3:27:06 PM

Rank: Soho66 Staff Member

Groups:

Joined: 7/9/2009
Posts: 60
Asterisk + FreePBX (Trixbox, Elastix, etc)

To connect your existing Asterisk with FreePBX solution to Soho66 for making & receiving calls, please follow the steps below. I've assumed that this is a clean installation of Asterisk / FreePBX so, you may need to change some details to suit your own particular installation.

Throughout this guide, replace [VoIP Username] with the VoIP Username of your Soho66 number [VOIP Password] with your VOIP Password, and [Domain] with your domain / registrar server. These can all be found in the "Voice over IP settings" section of your VoIP number configuration in "My Numbers" on our site.

SIP Trunk
First of all, a SIP Trunk is needed.

Create a new trunk, and fill in the following details:

Code:
Outbound Caller ID: [VoIP Username]

Trunk Name: Soho66

PEER Details:
  type=friend
  insecure=very
  nat=yes
  qualify=no    ; this is important!!
  canreinvite=no
  authuser=[VoIP Username]
  username=[VoIP Username]
  fromuser=[VoIP Username]
  fromdomain=[Domain]
  secret=[VoIP Password]
  host=[Domain]
  dtmfmode=rfc2833
  context=from-trunk
  disallow=all
  allow=alaw&ulaw&gsm
  port=8060

USER Context: from-trunk

USER Details:
  fromdomain=[Domain]

Register String: [VoIP Username]:[VoIP Password]@[Domain]/[VoIP Username]


Other fields not mentioned are to be left blank / with default values from FreePBX.

Submit the changes to the trunk. Don't worry about reloading the configuration just yet. There's more changes that we need to do first.

Extension
Secondly, an extension is needed for receiving / making calls. This is fairly standard within FreePBX and nothing special is needed for Soho66 so, I'll assume that you know what you're doing with this step.

Outbound Route
Next, an outbound route is needed for making calls through Soho66. Either create a new route, or modify the default 9_outside route if desired (for calls to be prefixed with 9 for external through soho66).

If you're creating a new route, ensure that it has a sensible name for internal management. In Dial Patterns, if you want to have the system use a prefix for dialling calls through Soho66, then enter the prefix, followed by a pipe symbol (|) followed by a full stop (.). The default 9_outside rule has a dial pattern of 9|. meaning that anything starting with a 9 will go through this route but, the pipe symbol will stop anything before the pipe (the 9 in this case) from being submitted to the trunk (Soho66).

For the Trunk Sequence, ensure that SIP/Soho66 is the only trunk that's in use (if you're editing the default rule, change ZAP/g0 to SIP/Soho66).

Submit the changes to the outbound route. Once again, don't worry about reloading the configuration at the moment.

Inbound Route
Lastly, you'll need an inbound route. Create a new route and fill in the following fields.

Code:
Description: Soho66 Inbound
DID Number: [VoIP Username]


In "Set Destination", choose where you want the inbound call to be routed to.

Once again, any other fields should be left as blank / the default which FreePBX supplies.
Submit the changes, then reload the configuration.

You should find now that, any calls received will be presented to your FreePBX extension.
ReginaldC
#2 Posted : Tuesday, August 25, 2015 7:36:06 PM
Rank: Member

Groups:

Joined: 6/6/2011
Posts: 19
Outbound Route
ok i found out you need for example outside line 9 | X.

or if on freepbx as i use its 9 for prefix then match pattern should be X.
ConorO2
#3 Posted : Monday, March 21, 2016 10:18:29 PM
Rank: Newbie

Groups:

Joined: 3/12/2016
Posts: 1
DarylB's instructions work fine for outbound routes. However, getting inbound calls to your FreePBX server requires a little more configuration and has some hidden “gotchas”.

In Soho66 routing wizard:

1. Select "Send the call to one or more internal/external destinations"
2. Add [VoIP Username]@[IP Address] to "External telephone numbers to ring"

where [IP Address] is the public IP address of your FreePBX server. Note that you cannot use a domain name (e.g. one provided by a DDNS service) instead of the IP Address - for some unknown reason Soho66 servers will not resolve domain names. As a consequence, if your broadband provider will not give you a static IP address you can not use FreePBX with Soho66 to receive inbound calls. This is clearly a very serious shortcoming as many residential users do not have, nor can they get, static IP addresses.

[Aside] It is not at all clear why Soho66 configuration requires you to provide an IP Address in the first place - this information is available to Soho66 servers when your FreePBX trunk registers with them. This is the approach taken by Blueface, for example, and anyone with an IP phone on their LAN will know that the registration process performed by the phone looks after telling Soho66's SIP server exactly where the phone is. [End Aside]

If your SIP server does not have a public IP address (as is usually the case) then you need to set up a port forwarding rule in your router e.g.

[IP Address]:8060 --> [LAN IP Address]:8060

where [LAN IP Address] is the local IP address of your FreePBX server.

You will also need to make the following change to FreePBX:
Asterisk SIP Settings --> Allow Anonymous Inbound SIP Calls=Yes

If FreePBX is still not handling inbound calls correctly check the Asterisk CLI to confirm that calls are at least finding their way to your FreePBX server.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Soho66 Theme by Daryl Burns (Soho66) (Soho66)
Powered by YAF 1.9.3 | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 4.985 seconds.